Inkscape/Začínáme

Z Wikiverzity
Skočit na navigaci Skočit na vyhledávání

Inkscape/Začínáme Předpokládáme, že máme nainstalovaný grafický editor Inkscape, že se nám jej podařilo spustit a hledíme na jeho okno.

Základ[editovat]

Posez[editovat]

Pro kreslení většinou používáme myš, avšak Inkscape má i velmi silnou podporu klávesnice. Každou věc lze zpravidla podniknout buď klávesnicí, nebo myší, nebo kombinací obojího, což bývá nejrychlejší způsob práce. Proto (jsme-li praváci) držíme pravou rukou myš a levou máme na klávesnici. Tímto způsobem budeme většinu akcí popisovat. (Další možnosti jsou uvedeny v příslušných návodech a manuálech.)

Terminologie[editovat]

Viz obrázek: inkscape window overview 3

Pokud chceme editovat nějaký SVG soubor (tedy obrázek), pak pro každý soubor bude spuštěna vlastní kompletní instance Inkscape, tedy kompletní okno editoru. Přepínat mezi okny můžeme buď pomocí okenního manažeru, anebo Ctrl-Tab.

Okno má v původním nastavení následující strukturu (popisujeme odshora dolů):

  • Menu [Menu] – v horní části okna:
    • Soubor [File]
    • Úpravy [Edit]
    • Zobrazení [View]
    • Vrstva [Layer]
    • Objekt [Object]
    • Křivka [Path]
    • Text [Text]
    • Efekty [Effect]
    • Whiteboard [Whiteboard]
    • Nápověda [Help]
  • Panely (pod menu):
    1. Panel příkazů [Commands Bar]
    2. [Snap Controls Bar] (při prvním spuštění se nezobrazuje)
    3. Panel s ovládacími prvky nástroje [Tool Controls Bar (Controls Bar)]
  • Nástroje [Toolbox] – po levé straně kreslícího prostoru
  • Kreslící prostor, vybavený vlevo a nahoře měřítky, na které lze umísťovat vodítka a z nich mohou vycházet mřížky [Rulers, Guides and Grids].
    • Plátno [Canvas], na kterém budeme kreslit, ohraničující náš výkres v kreslícím prostoru
  • Paleta barev [Color Palette]
  • Stavový řádek [Status Bar]

Nastavení[editovat]

Ještě než začneme cokoliv malovat, je dobré si nastavit vlastnosti dokumentu, který budeme vytvářet. Tj. otevřeme si nový dokument, provedeme příslušná nastavení a pak si dokument uložíme s názevem třeba "prázdný/svg", "moje_nastavení.svg" apod. Později si ten samý soubor můžeme otevřít, uložit si jej znova už s konkrétním názvem a začít v něm tvořit. Tím pádem můžeme jednodušše použít svoje vlastní nastavení pro všechny své SVG soubory, případně pro skupinu dokumentů, které mají vypadat stejně.

Nastavení pro dokument měníme v panelu Shift-Ctrl-D neboli Soubor → Vlastnosti dokumentu [Document properties]. Nejdřív ale musíme pochopit některé základní pojmy:

Souřadnice[editovat]

Je rozdíl mezi tím, jak Inkscape pracuje vevnitř a jak pak dokumenty ukládá ve standardu SVG formátu, a tím, jak se co jeví zvnějšku na plátně.

SVG (interně)[editovat]

  • Počátak souřadnic: Horní levý roh
  • souřadnice x, y rostou doprava a dolů (jako u psaného textu)

Na plátně (vnější pohled)[editovat]

  • Počátak souřadnic: Horní levý roh
  • Souřadnice x, y rostou doprava a nahoru (jako v geometrii)
  • Rozlišení: fixní 90 DPI
  • Jednotky:
    • 1 inch = 1/12 ft = 2.54 cm = 25.4 mm = 0.0254 m = 6 pc = 72 pt = 90 px
    • 1 cm = 35.433 px
    • defaultní jednotky se mění pro celý dokument ve Vlastnosti dokumentu → záložka Strana, Výchozí jednotky (cm mají každé pravítko jiné, mm pravítko mají dílky po 2.5mm, dost nelogické a blbě se v tom orientuje)
    • Různé parametry mohou být nastaveny v různých jednotkách (např. defaultní měřítko a mřížka; snapovací distance je v pixelech, nezávisle na jednotkách!)
  • Úhly: dvě možnosti, dají se údajně nastavit v Vlastnosti dokumentu → záložka Steps, Compass-like → display of angles; já jsem to tam nenašel, ale dá se na to dostat:
    • dvojklik na Výběr a transformace objektů (první ikonka Toolboxu, se šipkou vlevo nahoru), položka Kroky
    • geometricky (defaultně): 0° vpravo, leží na ose x, úhly rostou proti směru hodinových ručiček
    • geograficky, jako azimut na kompasu: 0° nahoře (jakoby sever), leží na ose y, úhly rostou po směru hodinových ručiček

Zachytávání (Snap)[editovat]

Umožňuje přesné kreslení tím, že se souřadnice "chytne" blízkého objektu. To je nutno též nastavit.

Mřížka (Grid)[editovat]

Umožňuje přesné kreslení do rastru. Může být:

  • Pravoúhlá – obvyklá pro 2D kreslení
  • Axnometrická – pro axonometrické promítání 3D objektů

Když dám nastavení mřížky na 2.5 mm, tak se mi ještě zobrazuje, ale při 2 mm už se mi nezobrazuje. S nastavením SnapSnap to grids to zžejmě nesouvisí, nevím, proč je to tak.

Vodítka (Guides)[editovat]

  • Vytvoření:
    • Pravoúhlá vodítka: tažení levým myšítkem od pravítka (Ruler)
      • tato vodítka se defaultně nechytají mřížky
    • Šikmá vodítka: tažení levým myšítkem od konce pravítka
      • v pravoúhlé mříži: defaultně 45°
      • v axonometrické mžíži: defaultně rovnoběžné se šikmou osou
  • Přesun:
    • opět levým myšítkem
  • Odstranění:
    • Odtáhneme je zpátky k pravítku
    • Najedeme na ně myší (zčervenají) a smažeme je deletem
  • Přesné umístění:
    • Shift-Ctrl-P = Nastavení Inkscape (Inkscape Preferences Dialog) → Guideline dialog (neobjevil jsem tam nikde)
    • nebo: dvojklik na Výběr a transformace objektů (první ikonka Toolboxu, se šipkou vlevo nahoru)
    • dtto s Edit paths by nodes (druhá ikonka Toolboxu, tři čtverečky ve čtvrtkruhu se šipkou)
    • dtto s Tweak objects ... (Tweak tool)
  • Odvození z objektu:
    • Shift-G neboli ObjektObjects to guides – vytvoříme objekt a dle něj nastavíme vodítka; tím se dá udělat i to přesné nastavení (objekt se chytí za mříž a pak je defaultně odmazat – odmazání se dá zabránit zatržením políčka Keep objects after conversion to guides)

Problémy[editovat]

  • Zaškrtávací políčko Snap only when closer than – nápověda říká: "Snapping distance, in screen pixels, for snapping to ...". Tedy je to v pixelech, nezávisle na defaultních jednotkách! U mříže stačí nevyplňovat, pak se to chytá vždy

Interface[editovat]

Více o základních způsobech ovládání:

Plátno[editovat]

Plátno je stránka, na které budeme kreslit. (I když ve skutečnosti je možno kreslit i do prostoru mimo něj.)

Velikost plátna si můžeme zvolit při otevření nového souboru (Menu: Soubor → Nový – otevře nové okno s čistým plátnem), případně potom změnit (Menu: Soubor → Vlastnosti dokumentu).

Například pro vytvoření prezentace určené k promítání na klasickém projektoru s poměrem stran 4:3 zvolíme Vlastní velikost' 280x210 mm (o něco zkrácený formát A4 naležato).

Plátnem lze pohybovat po ploše:

myš 3 Ctrl-šipky tažení všemi směry
kolečko myši dtto nahoru–dolů
Shift-kolečko myši dtto doleva-doprava

Náhled na plátno lze vizuálně zvětšovat a zmenšovat:

Ctrl-kolečko myši +, -

Tím pádem je možné i vypnout posuvníky Ctrl-B a zvětšit si tak prostor pro kreslení.

Panely[editovat]

Ikony v panelech jsou snadno dosažitelné myší, ale mají tu nevýhodu, že zabírají dost místa. (Časem je výhodnější naučit se používat klávesnici namísto klikání na panely.)

Panely lze zobrazit nebo skrýt příkazem z hlavního menu: Zobrazení → Zobrazit/Skrýt

Dále mají panely tu vlastnost, že je možno je za puntíkované držátko v levé části panelu vyjmout jako zvláštní okénko, kde budou umístěny formou roletového menu (zavřením takového okénka se panel vrátí zpět do hlavního okna).

To platí i pro toolbox na levé straně: kvůli jeho velké výšce totiž není možné změnšit výšku celého hlavního okna, které se potom nemusí vejít na plochu nízkých monitorů (např. u netbooku).

Na pravé straně panelů může být trojúhelníček: Po kliknutí na něj se rozvinou příkazy, které se už na panel nevešly. (Což pro toolbox neplatí, takže se kvůli němu právě okno zmenšit na výšku nedá.)

Editace[editovat]

Konečně začínáme kreslit:

  • Ctrl-Z navrátí editaci o krok zpět
    • Změny v Nastavení Inkscape to ale neovlivní, i když někdy se opticky vrátí dřívější nastavení mřížky (zřejmě chybka)
  • Shift-Ctrl-Z ji opět posune editaci o krok vpřed

Kreslení geometrických útvarů[editovat]

  • Vybereme kliknutím na útvar na panelu nástrojů a umístíme jej myší na plátno

Úprava nakreslených útvarů[editovat]

  • mezera–klik (nebo šipka na panelu nástrojů a klik): výběr objektu a první manipulace (černé šipky dovnitř a ven):
    • tažení za objekt – přesun
    • tažení za šipky – změna proporcí v daném směru
    • namísto taháním myší lze použít číselný vstup – čtyři políčka na panelu s ovládacími prvky
    • Ctrl-tažení za šipky – změna velikosti při zachování proporcí
  • další klik na objekt – druhá manipulace (černé šipky mají směr kolem dokola)
    • tažení za rohové šipky – rotace
    • Ctrl-tažení za rohové šipky – rotace po 15°
    • tažení za nerohové šipky – zkosení
    • Ctrl–tažení za nerohové šipky – zkosení po stupních
  • Esc – ukončení výběru

Mnohanásobný výběr[editovat]

  • myš – obdélníkový výběr
  • Shift-klik – výběr/odvýběr po objektech
  • Ctrl-A – vybere všechny objekty ve vrstvě

Skupina[editovat]

  • označit členy a Ctrl-G = vytvoření skupiny (možno hierarchizovat)
  • označit skupinu a Ctrl-U = rozpad nejvyšší úrovně skupiny
  • Ctrl-klik – označí jeden objekt ve skupině
  • Shift–Ctrl-klik – umožní označit více objektů ve skupině

Barvy[editovat]

Barva objektu[editovat]

  • při vybraném objektu (např. hned po nakreslení):
    • barva výplně a obrysu se zobrzuje v levém spodním rohu (levý konec stavového řádku) – kliknutím tam vyjede dialog pro změnu barvy
    • změna barvy:
      • výplně: klikneme levým myšítkem na paletu dole – vybarví se dle toho výplň objektu
      • obrysu: klikneme tam pravým myšítkem a vybereme Set stroke nebo stiskneme Shift + klik na vybranou barvu
  • pokud chceme další (nebo několik dalších) objektů stejně, uložíme si to k příslušnému objektu do Nastavení Inkscape (dvojklik na ikonku objektu)

Zarovnání[editovat]

  • Shift-Ctrl–A

Z-pořadí[editovat]

Zetová kóta = pořadí objektů při vytváření. Prí kreslení se objekty kladou stále víc nahoru (poslední může zakrýt předcházející).

  • Home, End přesune objekt nahoru nebo dospod
  • PgUp, PgDownn přesune objekt o jednu posici nahoru nebo dolů
  • Tab – prochází objekty odspoda nahorů (jak byly kresleny):
    • když není nic vybrané, vybere objekt nejvíc naspodu
    • jinak vybere objekt hned nad ním
  • Shift-Tab – prochází objekty odshora dolů:
    • když není nic vybrané, vybere objekt nejvíc nahoře
    • jinak vybere objekt hned pod ním
  • Alt-klik – vybírá schované objekty (postupně odshora dolů)
  • Alt-tažení – přemístí takový schovaný objekt

Tvary[editovat]

Tvar na křivku[editovat]

  • Ctrl-Shift-C – převede tvar na křivku (zpátky to nejde)

Nastavení stylu[editovat]

  • Vytvořím nějaký objekt
  • Menu → Objekt → Výplň a obrys – nastavím co chci
  • Na Panelu s ovládacími prvky nástroje (hned nad kreslícím prostorem) kliknu vpravo na "Výplň/Obrys"
  • Otevře se mi okno "Nastavení Inkscape"
  • Zvolím "Vlastní styl nástroje" a použiji tlačítko "Vzít z výběru" – tím se přenese poslední výběr do nastavení a další objekty se budou vytvářet stejným stylem

Přímka[editovat]

Inkscape kupodivu nemá mezi nástroji nástroj na vytváření přímek, ale použije se nástroj "Kresba Bézierových křivek a přímých čar" (Pen tool) Inkscape/Manuál#Bézier (Bézier with Pen).

Pokročilé[editovat]

Editace[editovat]

Na kopírování/vkládání textu používá Inkscape sytémovou schránku, jinak používá svoji vlastní:

  • Ctrl-C – Kopírování objektu (do schránky)
  • Ctrl-X – Vyjmutí objektu (do schránky)
  • Ctrl-V – Vložení objektu (ze schránky)
  • Ctrl-Alt-V – Vložení objektu (ze schránky) na stejné místo
  • Shift-Ctrl-V – Vložení stylu (ze schránky) na vybrané objekty
  • Vložit velikost

Zjednodušení[editovat]

  • Ctrl-L – zmenší počet bodů na křivce (vyhlazení čar)