GIMP/Juandev

Z Wikiverzity
Skočit na navigaci Skočit na vyhledávání

Tak, jelikož mi studovat podle příruček nešlo, tak se musím uchýlit ke zkoumání.

Problém 1: Vyříznout auto a dát ho na jiné pozadí[editovat]

Mám fotku auta a chci ho vyříznout a dát na jiné pozadí.

  • ptám se na kanálech #GIMP a #wikipedia-cs, navštivil jsem i video tutoriály a vybojoval první obrázkomix:
  • otevřu si obrázek, kde chci něco vyřezat
  • otevřu si Nástroje a kliknu na 3. tlačítko Free Select Tool
  • objedu s ním objekt
  • kliknu na Upravit --> Kopírovat
  • otevřu jiný obrázek ve kterém to chci umístit a kliknu na Upravit --> Vložit do
  • pak je třeba ve Vstvách (Windows --> Docable Dialogs --> Vstvy) kliknout na vloženou vrstvu --> Nová vstva...
  • pak jen stačí upravit velikosti jednotlivých vrstev. Pokud pracuji s velikostí a pozicí, musím mít v okně Vrstvy zapnutou vždy správnou vsrtvu.
  • Yes check.svg Hotovo--Juandev 20. 1. 2010, 14:07 (UTC)

Poznatky[editovat]

  • uvědomuji si, že již při focení bych měl mít jasno, k čemu budu fotku potřebovat
  • například pokud fotím auto pro webovky, měl bych se vyvarovat odlesků domů a nebe a fotit auto v garáži s externím osvětlením
    • to může být s odrazem toho světla z jedné strany
    • bez odrazu světla
  • prostě dle potřeb designu na webovce

Problém 2: Udělat výřez obrázku a uložit ho jako výřez[editovat]

  • naváži na předchozí zkušenost s řezáním a zkusím to vložit do nového souboru, kde bude vrstvou něco jako transparent
  • čili, opět použiji nástroj Free Select Tool (F) a obřežu auto
  • pak kliknu pravým tlačítkem myši Upravit --> Kopírovat (CTRL+C)
  • kliknu na Soubor --> Nový… (CTRL+N) --> Pokročilé volby --> Vyplnit s --> Průhlednost --> Budiž
  • v novém obrázku kliknu pravým tlačítkem myši Upravit --> Vložit do
  • ve Vrstvách, ke kterým bych se dostal přes CTRL+L) kliknu na vloženou vrstvu pravým tlačítkem myši --> Plovoucí výběr --> Nová vrstva…
  • Uložil jsem jako jpg. Což je ale špatně a musí vše opakovat:
    • tentokrát, abych to urychlil, jsem použíl jpeg obrázek s bílým pozadí a Inteligentních nůžek(I) z panelu Nástroje
    • když je obřízlo musím kliknout levým tlačítkem myši a pak mohu teprve kopírovat
    • obdobně otevřu nový soubor s jednou transparentní vrstvou
    • na kanále #gimp mi doporučují 2 formáty: XCF a MNG, které ale nejsou podporovány na webu
    • pak se hovoří o GIF formátu, který s tím má ale problémy a proto doporučují PNG
    • ukládám zkušebně jeden soubor do GIFu a druhý do PNG, samozřejmě zálohu do XCF
    • výsledek, je že GIF očividně zhoršil kvalitu a vskutku je to formát pro jednoduché grafické předměty s několika málo barvami --> v malém rozlišení na webu to není tak znát. Nicméně by se teoreticky tato technika dala udělat k vytvoření pastelkovitě umělého vzhledu, kdyby nebyla proti sémantice věci.
    • na druhou stranu ten PNG soubor je mnohem lepší ve zvětšení i na webu, ale otázka je, jestli to není proti sémantice věci. Pojďme si to zopakovat:
      • GIF (Graphics Interchange Format) - pro obrázky s malým počtem barev - nepodporuje dobře přechody barev; animované obrázky; rastrový formát
      • PNG (Portable Network Graphics) - pro pérovky. Pozor IE6 ho nepodporuje!; je to bezstrátová bitmapa; byl vyvinut jako náhrada GIFu, když u GIFu byly majetkové spory.
      • JPEG (Joint Photographic Experts Group) - pro fotografie a obrázky z více barvami; je to ztrátový formát, což znamená, že při vyšší kompresy se ztratí data a obrázek se stává méně ostrým; přechody jsou rozostřené; také existují bezstrátové JPEGy, ale ty nemají širší podporu. Nepodoruje transparentnost!
        • -->Toto jsou 3 široce podporované formáty pro web. Jelikož JPEG to nepodporuje zbívají GIF a PNG. GIF to ale dosti zkresluje, PNG ne. Tyto formáty ale pro to nejsou dělány, proto bude nejlepší používat aktuální pozadí stránky a formát JPEG. V krajních případech PNG.
      • XCF (eXperimental Computing Facility) je formát GIMPu umožňující ukládat vše co GIMP umí vyrobit (např. vrstvy). Neukládá to ale historii. Není doporučován jako exportní formát, protože mezi jednotlivými verzemi mohou být drobné odchylky, přesto se používá i v dalších aplikacích.
      • MNG (Multiple-image Network Graphics) je to vlastně verze PNG podporující animace. IE, Opera ani Safari ho nepodporují. Nemá zaregistrovaný MIME type. Na web se může umísťovat jako <object>. Pokud je kódován PNG je bezstrátový, jako JNG (JPEG Network Graphics) ztrátový.

Postřehy[editovat]

  • Abych mohl dobře obřezávat, potřeboval bych fotit s vyšším rozlišením a koupit si nějakou eletronickou tužku, která se drží lépe než myš.--Juandev 21. 1. 2010, 13:43 (UTC)
  • Určitě bych si měl rozdělaná díla ukládat v tom jejich formátu *.xcf.--Juandev 21. 1. 2010, 13:43 (UTC)
  • JPG nepodporuje transparentnost.
    • V souvislosti s problémy u transparentnosti (česky průhlednosti) bych mohl ty výřezy dávat na pozadí jako je na stránce, čímž bych se vyhnul problému s tím, že budu nesémanticky tvořit obrázky pro web.--Juandev 21. 1. 2010, 13:43 (UTC)

Problém 3: Výřez a zoom o určité velikosti[editovat]

Cílem tohoto problému je vyřešit jakým způsobem se dají připravit fotografie pro tisk pexesa. Jde o to, že jsou to fotografie různých formátů a velikostí a různé kvalitě. Jde tedy o to, připravit výřezy o určité velikosti a vysoké kvalitě. Zatím se mi dařilo dělat výřezy, ale klesala viditelně kvalita.--Juandev 22. 1. 2010, 13:58 (UTC)

Vlastně si teď uvědomuji, že bych to pexeso měl celé navrhnout v GIMPu, protože u každého obrázku bude velikost hrany jiná.--Juandev 22. 1. 2010, 13:58 (UTC)
  • zkoumám jak otevřít obrázek stránky a zjišťují, že GIMP není vhodným nástrojem pro tvorbu pexesa. Asi to sem také sémanticky nepatří.
  • čili po tom co jsem ve Scribus vyrobil návrh pexesa, přicházím do GIMPu, abych si připravil fotografie
    • jde o to vyřezat fotografie nebo zmenšit, tak aby nedošlo ke ztrátě kvality
    • bude se to muset řešit zvláště u fotografií, které nejsou čtvercové nebo jsou špatně kompozičně řešené
    • dále jde o to, aby v dolní části bylo místo pro nápis - možná?
  • čili začal jsem nápovědou, abych furt neotravoval na kanále
    • jsem zde: [1]
      • dozvídám se, že obrázek se objevuje vždy v přijatelné velikosti, aktuální zmenšení/zvětšení je dole v procentech pod obrázkem, zde si to taky mohu nastavit
      • hned jsem našel chybu v tutoriálu, tak se pokouším zaregistrovat do jejich bugzilly: no to je kapitola sama pro sebe, prostě ve výše zmíněném linku nemá být: „Problem: you have a huge image and you want to resize the is so that it will display nicely on a web page.“, ale „Problem: you have a huge image and you want to resize the image so that it will display nicely on a web page.“
        • nemá cenu se tím zabývat, ta nápověda je celá stará
      • v horní části záložky okna je pak jméno souboru a v závorce mód a počet vrstev, zatím velikost (zřejmě v pixelech) a jméno GIMP, mód by měl být RGB, pokud není je třeba ho do RGB nastavit
        • RGB (Red Green Blue - složky jednoho pixelu, každý z těchto pixelů pak může nabývat intenzitu 0–255) je pro barevně kvalitní fotografie
        • Indexed je o redukci velikosti souboru a také o málo barvách, méně než 256. Na výběr jě několik standardizovaných palet nebo moje vlastní.
        • Grayscale jsou stupně šedi, což může být někdy sexi.
      • čili Image --> Scale Image…
        • zjišťuju, že hned první obrázek není čtverec – pokusím se tedy o čtvercový výběr
          • otvírám si: [2]
            • kliknu na CTRL+C a myší táhnu
            • když to chytnu v rozích mohu táhnout šikmo na stranách pak mohu táhnout strany
            • je třeba si na to otevřít pomoc Windows --> Docable Dialogs --> Tool Options, pokud mám ten tool označen
    • informace o obrázku se dozvím tak, že kliknu na ALT+ENTER, nebo Image --> Image Properties
    • jinak pokud je obrázek menší než výřez, který potřebuji, tak si napřed v tom samém obrázku udělám výřez největšího možného čtverce. Pak si otevřu nový soubor o danné velikosti s transparentní vrstvou a původní výřez tam překopíruji. Následně obě vrstvy sloučím a nový soubor uložím.
    • ve Scribusu sice funguje možnost Adjust Image to frame, ale pokud obrázek není čtvercový, tak to k ničemu není

Problém 4: Jak se vynutí GIMP v angličtině[editovat]

Z nějakého důvodu mám GIMP v češtině. Asi protože jsem Čech. Vzhledem k tomu, že nění ale u tohoto prvotřídního softwaru jentak přepnout jazyk, zařazuji to jako bod 4.

  • hledám v nápovědě
    • nálézám prostou nápovědu: Control Panel → System → Advanced → Environment
    • nj, ale jak to kdo přeložil česky?
    • usuzuji, že se jedná o změnu jazyka operačního systému, což ale nechci
    • ha moudrá rada na kanále, že jazyk můžu v systému nastvit pouze pro GIMP
      • zatím se ruší, viz následující
    • naistalovat GIMP bez jazykových balíčků
      • a ono se to povedlo. Ten šťastlivec co má pochopení pro Vidláky se jmenuje Phil
  • co kdybych tedy český překlad smazal, nebo nahradil opět anglickým?
    • nenašel jsem překladové soubory

Vynucení jazyka[editovat]

Upravit --> Předvolby --> Rozhraní --> Jazyk (vybrat)Yes check.svg Hotovo--Juandev 15. 2. 2012, 11:47 (UTC)

Yes check.svg Hotovo--Juandev 25. 1. 2010, 19:01 (UTC)

Problém 5: Zmenšení velikosti obrázků[editovat]

Na Aukro potřebuji nahrát obrázky. Ale prý jsou moc veliké. Takže zkoumám jak na to v GIMPu. Čili řešení problému jsou 2:

  • jednak dám File --> Save As… --> změním jméno a Save --> Quality: nastavím např. na 30 --> Save – nevýhodou je, že bez uložení nevidím jak bude obrázek vypadat
  • další možností je obrázek škálovat, ale to je zbytečně zdlouhavé. Jedná se de facto, o změnu rozměrů x, y.

Yes check.svg Hotovo--Juandev 18. 3. 2010, 11:12 (UTC)

Problém 6: Jak zesvětlit obrázek[editovat]

Zatím dělám přes Colors --> Curves, ale je to dobře? Jak to funguje?--Juandev 19. 10. 2010, 09:01 (UTC)

Problém 7: Když mi někdo říká, že podexponováno, co s tím[editovat]

Vrtbovská zahrada, sala terrena, průhled do krajiny - freska (002).JPG

--Juandev 19. 10. 2010, 09:01 (UTC)

Problém 8: Jak otočit celý obrázek o 90o?[editovat]

Image --> Transform --> Rotate 90o

Yes check.svg Hotovo--Juandev 30. 1. 2012, 15:16 (UTC)

Problém 9: Jak přidat záložku s barvami do toolboxu?[editovat]

Problém 10: Jak v GIMPu zacházet s toolboxem?[editovat]

Problém 11: Jak přidat Bucket Fill Tool do spodní části toolboxu?[editovat]

Problém 12: Jak se opavuje perspektiva?[editovat]

Problém 13: Jakým způsobem odstranit chromatické aberace?[editovat]

Nějaký plug in do GIMPu--Juandev (diskuse) 23. 8. 2014, 10:08 (UTC)

V návodu se píše, že se má skript umístit do adresáře skriptů, ten však není na první pohled vidět. Umístění adresáře se zjistí z GIMPu: Edit --> Preferences --> Folders --> Scripts

Dále nápověda radí, že mám obnovit registry skriptů. Zřejmě se to dělá následovně v GIMPu: Filters --> Script-Fu --> Refresh Scripts nebo restartem GIMPu

Nápověda dále praví, že mám spustit skrypt. Ale jak? Taková nápověda je slušně řečeno na nic. Aha, takže daný skript lze spustit až když je natažený nějaký obrázek a sice následovně: Script-Fu --> Darla --> Purple Fringe

A co dál?--Juandev (diskuse) 25. 8. 2014, 09:01 (UTC)

Problém 14: Jak smíchat 2 obrázky?[editovat]

Problém 15: Jak se zbavit defektů klonováním?[editovat]

Je řada cest, záleží na podkladové barvě. V tomto případě se jedná o hnědou texturu.

Problém 16: Jak získat Tool options?[editovat]

Viz video.Yes check.svg Hotovo--Juandev 15. 2. 2012, 11:47 (UTC)

Problém 17: Jak dockovat toolbox a podobné?[editovat]

Windows --> Single-Window ModeYes check.svg Hotovo--Juandev 15. 2. 2012, 11:47 (UTC)

Problém 18: Jak rozložit dokovatelná okna?[editovat]

Viz video.Yes check.svg Hotovo--Juandev 15. 2. 2012, 11:47 (UTC)


Problém 19: Blur nefunguje[editovat]

Snažím se rozmazat obrázek rozmazávátkem, ale nefunguje to.


Problém 20: Jak zavřít otevřený snímek a nezavřít GIMP?[editovat]

CTRL+W --> Discard Changes

Problém 21: Jak vybrat několik objektů a dále s nimi pracovat?[editovat]

Videotutoriály: vrstvy a výběr[editovat]

Postup[editovat]

Například na místo výběru jednotlivých objektů lze vybrat to co chci odstranit. Třeba funkcí laso v módu "Add to the curent selection" mohu provést více výběrů naráz (nemůžu ale provést výběr uvnitř již existujícího výběru (proto je potřeba to trochu promyslet). Pak udělám pozadí průhledným tak, že Layer - Transparency - Add To Alpha Channel a stisknu delete. Následně mohu dát Invert výběru a vybrat objekty, které chci upravovat. Pokud potřebuji odejít, tak to uložím jako xcf soubor.--Juandev (diskuse) 4. 9. 2015, 13:54 (UTC)

Problém 22: Bucket Fill Tool neraguje[editovat]

Mám obrázek ve kterém potřebuji změnit barvu určité plochy.

Tak jsem došel k tomu, že musím přepnout z módu Indexed do módu RGB v záložce Image. Co to je nevím, ale funguje to.

Problém 23: Jak editovat text?[editovat]

Například: mám nějaký text na pozadí je fotka. Tento text chci změnit, ale obrázek je ve formátu jpg.