Ubuntu/Precise/instalace/problémy

Z Wikiverzity
Skočit na navigaci Skočit na vyhledávání

Instalace[editovat]

Instaluji na Mivvy m310 z USB FlashDisku 1 GB, v jiném USB portu mám zasunutý prázdný nový USB FlashDisk Kingston 16 GB.

Příprava k instalaci Ubuntu[editovat]

- hodně dlouho to trvá, pak se objeví okénko:

ubi-partman crashed
ubi-partman failed with exit code 10. Further information may be found in /var/log/syslog.
Do you want to try running this step again before continuing? If you do not, your installation
may fail entirely or may be broken
      [Quit] [Continue anyway] [Try again]

[Try again] vede k té samé hlášce, stejně tak jako pokus o zavření tohoto okénka.

Není mi jasné, jak se podívat do /var/log/syslog ? Kde otevřít v tuto chvíli terminálové okno? Zkouším Alt-F1 atd., ale nic.

Mezitím se projeví blikání jasu obrazovky, které nelze zastavit, a tak jsem vypnul jsem stroj a zkouším se pak podívat na instalační FlashDisk, ale netuším, kde by tam byl nějaký přístupný filesystém, na kterém by byl ten /var/log/

Googluji problém "ubi-partman failed with exit code 10" a nacházím:

  • http://ubuntuforums.org/showthread.php?t=1498417 - tenhle chudák měl ten samý problém už v roce 2010 s verzí 10.04 a nikdo mu s ním neporadil. K tomu /var/log/ se nakonec nějak dostal, ale netuším, jak. (V jeho případě byl ale problém v jakémsi raidovém poli, což není můj případ.)

Znova nabootuji, jdu na [Vyzkoušet Ubuntu]. Po chvíli ztmavne obrazovka a pao se objeví okno:

The system is running in low-graphics mode
You screen, graphic card, and input device settings
could not be detected correctly. You will need to configure these yourself.

Což je divné, protože včera to běželo ze stejného live-flashdisku v pohodě. Na [OK] se nedá kliknout, protože mezitím přestala fungovat myš i touchpad - ne, nepřestala, jen černý kursor ve tvaru X byl schovaný někde za černým okrajem zobrazovaného pole.

Nabídka:

  • pokračovat v low-graphic
  • rekonfigurovat grafiku
  • troubleshoot the error
  • Exit to console login

Jdu na konsoli, kde vidím hlášky:

sd 3:0:0:0: [sdc] Asking for cache data failed
sd 3:0:0:0: [sdc] Assuming drive cache: write through

Mám k disposici 6 virtuálních textových konsolí pod Alt-F1 až Alt-F6; na Alt-F7 jsou ty chybové hlášky. Ty hlášky také běží na první konsoli.

Koukám na /var/log/syslog a vidím, že jsou tam zachované všechny logy, i ty včerejší, od 19:08:29, kdy jsem nejspíš poprvé nabootoval. Časy jsou nejspíš v GMT, historie verzí této stránky zřejmě také - první verze je z 18:05, tak koukám na ten čas. Vybírám jen nějaké okamžiky:

  • 17:43:03 kernel: imklog .... /proc/kmsg started = tady se začíná logovat po nabootování
  • řeší se cpu, BIOS, memory, ACPI + pci, pnp, pci_bus, ehci_hcd, uhci_hcd
  • 17:43:03 ata1.00: TOSHIBA
  • 17:43:03 scsi 2:0:0:0: Direct-Access Kingmax USB2.0 FlashDisk = to je ten, na kterém je to ubuntu live
  • 17:43:03 sd 2:0:0:0: [sdb] ... 1.01 GB = jo, to je ono
  • 17:43:03 sd 3:0:0:0: [sdc] Asking for cache data failed
  • 17:43:03 sd 3:0:0:0: [sdc] Assuming drive cache: write through
  • 17:43:03 sd 3:0:0:0: [sdc] Asking for cache data failed
  • 17:43:03 sd 3:0:0:0: [sdc] Assuming drive cache: write through
  • filesystémy na sda
  • 17:43:04 bluetooth, modem-manager, wifi r8180, NetworkManager: eth1, wlan
  • 17:43:10 dhclient
  • 17:43:38 ubuntu rtkit-daemon: Successfully called chroot =
  • 17:44:06 ubuntu ubiquity: switched to page language
  • 17:44:13 ubuntu ubiquity: switched to page prepare
  • 17:44:13 ubuntu ubiquity: switched to page language
  • 17:44:19 usb 1-1: new high-speed USB device nymber 7 using ehci_hcd = to jsme zasunul nový USB disk
  • 17:44:19 scsi4: usb-storage 1-1:1.0
  • 17:44:19 scsi 4:0:0:0: - Direct-Access Kingston DT Micro
  • 17:44:34 ubuntu localechooser: info: Language = 'cs'
  • 17:44:46 ubuntu ubiquity: switched to page prepare
  • 17:44:48 kernel: sd 3:0:0:0: [sdc] Test WP failed, assume Write Enabled
  • 17:44:16 ubuntu ubiquity: Tcaceback

Tím syslog končí, pak došlo k vypnutí stroje. Tak z toho nechápu, s čím měl ten ubi-partman problém.

Namontuji si jenu partition HDD a zkopíruji si na na tento syslog pro další studium.

Přebootuji a zkouším instalovat podruhé. Tentokrát nezasouvám ten USB FlashDisk - Ubuntu hrabe dlouho po disku, ale nakonec se ten problém s ubi-partmanem neopakuje.

Typ instalace[editovat]

Volím * Something else - vlastní partitions atd.

Vidím sda. Zasunu 16 GB USB FlashDisk a dám [Vrátit zpět] Scanning disc... a nevidím ho tam

Dám [Zpět] a pak znovu [Pokračovat]; zase dlouho točí hodiny a teď už tam konenečně vidím /dev/sdd a /dev/sdd1 15720 MB, tak to bude asi ono. Když ale na něj kliknu a dám [Změnit...] a řeknu, že to chci přeformátovat na ext4 a použít jako root, tak se na tom nakonec nic nezmění.

Kliknu na [Nová tabulka oddílů...] a zase nic.

Tak nastavím kursor na tu /dev/sdd1 a dám [Smazat] a tentokrát pro změnu:

ubi-partman crashed
ubi-partman failed with exit code 141. Further information may be found in /var/log/syslog.
Do you want to try running this step again before continuing? If you do not, your installation
may fail entirely or may be broken
      [Quit] [Continue anyway] [Try again]

Dám [Continue anyway], dostanu se na další obrazovku Kde jste? Kliknu na [Zpět] a neděje se nic. Tak dám [Ukončit], zeptá se mě, jestli doopravdy ukončit, a pak skoro zmrzne. Tedy kursor myši sleduje stále pomaleji a trhaně, pak se objeví jen základní okno X, pak pomalu přejde do textového módu, kdy ještě běhají ty obvyklé hlášky

sd 3:0:0:0: [sdc] Asking for cache data failed
sd 3:0:0:0: [sdc] Assuming drive cache: write through

pak obrazovka ztmavne docela, ale pořád to nevypadá, že by comp rebootoval anebo se vypnul. Až po delší době se objeví známé okénko:

The system is running in low-graphics mode
You screen, graphic card, and input device settings
could not be detected correctly. You will need to configure these yourself.

... atd., tentokrát pro změnu zkusím, co udělá Reconfigure graphics: Vrhne mě to do textového módu, nejdříve

Welcome to Ubuntu

a pak už jen opět snámé hlášky

sd 3:0:0:0: [sdc] Asking for cache data failed
sd 3:0:0:0: [sdc] Assuming drive cache: write through

- to mě to hodilo na sedmou konsoli. No tak co, opět si zkopíruji syslog na HDD a končím opičím trojhmatem Ctrl-Alt-Del