SigViewer/0.5.0/Ubuntu/10.10-10.04

Z Wikiverzity
Skočit na navigaci Skočit na vyhledávání

SigViewer/0.5.0/Ubuntu/10.04 = pokus o instalaci binárky, určené pro Ubuntu 10.10, pod Ubuntu 10.04

Info[editovat]

  • uvolněno: 2010-12-20
  • binárka (Ubuntu/Maverick): sigviewer-0.5.0-ubuntu1010-i386.deb

Ubuntu/Lucid[editovat]

  • instaloval jsem pod starší verzí Ubuntu/Lucid – instalace prošla
  • po spuštění ale:
 symbol lookup error: sigviewer: undefined symbol: _ZN9QListData11detach_growEPii

Možná je to chyba v závislostech? Možná v libqt?

Package: sigviewer
Version: 0.5.0
Depends: libqtcore4 (>= 4.7), libqtgui4 (>= 4.7), libqt4-xml (>= 4.7)

Nyní v Ubuntu 10.04 mám:

Package: libqtcore4
Version: 4:4.6.2-0ubuntu5.1
Package: libqtgui4
Version: 4:4.6.2-0ubuntu5.1
Package: libqt4-xml
Version: 4:4.6.2-0ubuntu5.1

Jen se dívím, že

apt-get check

nehází žádnou chybu.

Anebo ten symbol je z libgdf0 ? Ale když libgdf0 není uvedena v závislostech, je přilinkována staticky?

Zajímalo by mě, jak najít, kde je zakopaný pes? Bezvýsledně jsem zatím zkoušel použít utility:

  • ldd
  • dpkg-shlibdeps
  • deb-symbols
  • dpkg-gensymbols
  • nm
  • gdb

Googlím a kde nic tu nic, nějaký obecný postup, jak takové případy řešit.